4

Opis zmian w programach, zrealizowanych w 2023 roku dla wersji programów na 2024 rok :

Jak co roku, autor przygotował nowe, zmienione wersje programów czyli tzw upgrade, dostosowane do :

q zmian przepisów prawa,

q zmian w technologii sprzętu komputerowego,

q zmian wersji oprogramowania systemowego (MS Windows),

q potrzeb zgłaszanych przez użytkowników oraz

q pozbawione sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Ponadto od kilku lat użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samorozpakowywujacy się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Wybierz program ze spisu treści, znajdującego się w oknie po lewej stronie od tego tekstu.


UPGRADE 2001

Opis zmian w programie ”System finansowo-księgowy” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Usunięto błąd przy generowaniu pliku JPK na żądanie z księgami rachunkowymi firmy o nazwie KR_JPK. Podczas generowania pliku każde konto zakładowego planu kont było zgodnie z ustawą przyporządkowywane do jednej z 8 zdefiniowanych grup kont. Autor zapomniał, że w planie kont mogą być konta rozpoczynające się od cyfry 9; na przykład konto "999", które jest kontem technicznym do bilansowania każdego z kilku dokumentów BO. Błąd naprawiono; zdefiniowano bowiem i dodano 9 grupę kont w planie kont o nazwie "Konta techniczne".

2024.00/02

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.

2024.00/03

W związku z obowiązkiem elektronicznego przekazywania na żądanie Urzędu Skarbowego dokumentacji księgowej w formie plików JPK Autor aplikacji kontynuował w 2023 roku pracę nad:

  • dostosowaniem do tych żądań struktury i zawartości bazy danych tej aplikacji oraz
  • zaprogramowaniem procedur umożliwiających wygenerowanie na podstawie bazy danych tej aplikacji pliku JPK zgodnego z ujawnioną przez MF strukturą XML o nazwie "KSIĘGI RACHUNKOWE"; kod systemowy "JPK_KR" .

Prace nad tym plikiem nabierają szczególnego znaczenia w świetle przewidywanej w najbliższym czasie zmiany przepisów, które zobowiążą podmioty prowadzące działalność gospodarczą do :

  • prowadzenia ksiąg rachunkowych i podatkowej księgi przychodów i rozchodów przy użyciu programów komputerowych oraz
  • elektronicznego przesyłania ich cyklicznie w formie ustrukturyzowanej czyli w formie pliku XML

Plik "KSIĘGI RACHUNKOWE" (JPK_KR), przekazywany dotychczas do Urzędu Skarbowego na żądanie będzie po znowelizowaniu XML-owej struktury elektronicznie przekazywany w sposób cykliczny :

  • w trakcie roku do 20 dnia następnego miesiąca dla podatników rozliczających dochód miesięcznie lub do 20 dnia miesiąca kończącego kwartał dla podatników rozliczających dochód kwartalnie
  • na koniec roku do upływu terminu dla złożenia zeznania za dany rok podatkowy

2024.00/04

Głównym zadaniem w 2023 roku było programowanie pliku JPK_VAT generowanego przez aplikację do prowadzenia rejestrów zakupu i sprzedaży vat o nazwie XWRZS.EXE, która jest integralną częścią systemu finansowo-księgowego.

2024.00/05

W związku z planowanym uruchomieniem Krajowego Systemu e-Faktur, autor przygotowywał w 2023 roku zmiany w tej aplikacji które umożliwią współpracę aplikacji z tym systemem.

Obowiązkowe przystąpienie podmiotu gospodarczego do Krajowego Systemu e-Faktur jest przewidywane na dzień 1 lipca 2024 roku, zarówno po stronie wystawcy jak również po stronie odbiorcy faktury.


Opis zmian w programie ”Rejestr zakupu i sprzedaży vat” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.

2024.00/02

Po rozpoczęciu reinstalacji programu na 2023 rok ale jeszcze w 2022 roku zmieniono procedurę dopisywania do rejestru nowej faktury zakupu. Po wprowadzania numeru dopisywanej faktury zakupu aplikacja sprawdzała dotychczas czy użytkownik nie wprowadził już wcześniej w bieżącym miesiącu do rejestru faktury o tym samym numerze dla tego samego klucza dostawcy.

W nowej wersji rozszerzono okres w którym aplikacja sprawdza czy nie nastąpi podwojenie zapisu z fakturą zakupu do miesięcy poprzedzających miesiąc bieżący.

Jeśli data wystawienia dopisywanej faktury dotyczy roku :

  • bieżącego to kontrola podwojenia jest realizowana w okresie od m-ca wystawienia faktury do m-ca poprzedzającego m-c bieżący
  • poprzedniego to kontrola podwojenia jest realizowana w okresie od STYCZNIA bieżącego roku do m-ca poprzedzającego m-c bieżący

Uwaga :

Od dłuższego czasu przepisy VAT pozwalają rejestrować faktury zakupu po 3 miesiącach od daty wystawienia, a jeśli przyjmiemy miesiąc przesunięcia na ich dostarczenie to nawet po 4 miesiącach. W związku z tym zdarzało się, najczęściej w biurach rachunkowych, że podczas rejestracji faktur zakupu podwajano ich zapisy w rejestrze. Naprawa błędów podwojenia była możliwa tylko i wyłącznie w drodze korekty plików JPK, zmniejszającej podatek naliczony i wiążącej się z dopłatą VAT-u wraz z odsetkami.

2024.00/03

Po rozpoczęciu reinstalacji programu na 2023 rok ale jeszcze w 2022 roku; dokładnie 21.12.2022 poprawiono błąd uniemożliwiający użytkownikowi zrealizowanie zamknięcia rejestru w bieżącym miesiącu sprawozdawczym. Poprawiony błąd powstał podczas wprowadzania zmian w tej procedurze dla wersji 2022.12.

2024.00/04

W dotychczasowej wersji, w części deklaracyjnej pliku w pozycjach 68,69 wykazywana była odpowiednio zbiorcza wysokość korekty podstawy opodatkowania oraz podatku należnego dla faktur sprzedaży :

  • ze znakiem minus po upływie ustawowego terminu zapłaty faktur jak również
  • ze znakiem plus po zapłacie przeterminowanych faktur

Poprawiono ten błąd bo przepisy wymagają oznaczenia tych faktur znacznikiem korekty podczas ich rejestracji po upływie terminu jak również po zapłacie ale po zapłacie podstawa opodatkowania i podatek należny (ze znakiem plus) faktur nie powinny być dodadawane odpowiednio do zbiorczej wysokości korekty podstawy i podatku w pozycjach 68,69 w części deklaracyjnej pliku.


Opis zmian w programie ”Raport kasowy” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.


Opis zmian w programie ”Księga Przychodów i Rozchodów” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.')

2024.00/02

W związku z obowiązkiem elektronicznego przekazywania na żądanie Urzędu Skarbowego dokumentacji księgowej w formie plików JPK Autor aplikacji kontynuował w 2023 roku pracę nad :

  • dostosowaniem do tych żądań struktury i zawartości bazy danych tej aplikacji oraz
  • zaprogramowaniem procedur umożliwiających wygenerowanie na podstawie bazy danych tej aplikacji pliku JPK zgodnego z ujawnioną przez MF strukturą XML o nazwie "PODATKOWA KSIĘGA PRZYCHODÓW I ROZCHODÓW"; kod sys."JPK_PKPiR" ')

Prace nad tym plikiem nabierają szczególnego znaczenia w świetle przewidywanej w najbliższym czasie zmiany przepisów, które zobowiążą podmioty prowadzące działalność gospodarczą do :

  • prowadzenia ksiąg rachunkowych i podatkowej księgi przychodów i rozchodów przy użyciu programów komputerowych oraz
  • elektronicznego przesyłania ich cyklicznie w formie ustrukturyzowanej czyli w formie pliku XML

Plik "PODATKOWA KSIĘGA PRZYCHODÓW I ROZCHODÓW" (JPK_PKPiR), przekazywany dotychczas do Urzędu Skarbowego na żądanie będzie po znowelizowaniu XML-owej struktury elektronicznie przekazywany w sposób cykliczny :

    1. w trakcie roku do 20 dnia następnego miesiąca dla podatników rozliczających dochód miesięcznie lub do 20 dnia miesiąca kończącego kwartał dla podatnik rozliczających dochód kwartalnie
    2. na koniec roku do upływu terminu dla złożenia zeznania za dany rok podatkowy

2024.00/03

Głównym zadaniem w 2023 roku było programowanie pliku JPK_VAT generowanego przez aplikację do prowadzenia rejestrów zakupu i sprzedaży vat o nazwie XWRZS.EXE, która jest integralną częścią tej aplikacji na księgę podatkową.

2024.00/04

W związku z planowanym uruchomieniem Krajowego Systemu e-Faktur, autor przygotowywał w 2023 roku zmiany w tej aplikacji, które umożliwią współpracę aplikacji z tym systemem.

Obowiązkowe przystąpienie podmiotu gospodarczego do Krajowego Systemu e-Faktur jest przewidywane na dzień 1 lipca 2024 roku, zarówno po stronie wystawcy jak również po stronie odbiorcy faktury.


Opis zmian w programie ”Fakturowanie i rozliczenie sprzedaży” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Na wydruku krajowych faktur w walucie typu "EX" z VAT-em przeliczonym na PLN umieszczona jest dodatkowo : nazwa i numer rachunku banku, na który kupujący powinien wpłacić kwotę vat-u w PLN

2024.00/02

Skrócenie tekstu danych bankowych opisanych dla zmian aplikacji w poprzedniej wersji.

2024.00/03

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.

2024.00/04

W związku z obowiązkiem elektronicznego przekazywania na żądanie Urzędu Skarbowego dokumentacji księgowej w formie plików JPK Autor aplikacji kontynuował w 2023 roku pracę nad :

  • dostosowaniem do tych żądań struktury i zawartości bazy danych tej aplikacji oraz
  • zaprogramowaniem procedur umożliwiających wygenerowanie na podstawie bazy danych tej aplikacji pliku JPK zgodnego z opublikowaną przez MF strukturą XML pliku JPK o nazwie "FAKTURY VAT"; kod systemowy "JPK_FA"; wersja 4

Uwaga : dotychczas sporządzany na żądanie Urzędu Skarbowego plik "FAKTURY VAT" (JPK_FA) prawdopodobnie od lipca 2024 roku nie będzie wymagany bowiem jego zawartość będzie identyczna z wymogami struktury Krajowego Systemu e-Faktur.

2024.00/05

W związku z planowanym uruchomieniem Krajowego Systemu e-Faktur, autor przygotowywał w 2023 roku zmiany w tej aplikacji które umożliwią współpracę aplikacji z tym systemem.

Obowiązek przystąpienia podmiotu gospodarczego do Krajowego Systemu e-Faktur, jest przewidywany na dzień 01.07.2024, zarówno po stronie wystawcy jak również po stronie odbiorcy faktury. W związku z tym autor przewiduje pełne przygotowanie aplikacji do współpracy z KSEF-em dopiero w kwietniu 2024 roku.

Uwaga : w ramach dostosowania aplikacji do Krajowego Systemu e-Faktur konieczne będzie stworzenie procedury generowania na podstawie wystawionych za pomocą tej aplikacji faktur XML-owego pliku o aktualnie obowiązującej strukturze.

2024.00/06

Głównym zadaniem w 2023 roku było zaprogramowanie procedury generowania miesięcznego pliku JPK_VAT zawierającego : część deklaracyjną oraz ewidencyjną ze sprzedażą podatnika. Plik ten jest od 1 października 2020 roku generowany przez tą aplikację i może być agregowany z plikiem JPK_VAT zawierającym w części ewidencyjnej zakupy podatnika, a wygenerowanym przez inną aplikację Autora do prowadzenia rejestrów zakupu i sprzedaży vat.

Uwaga: wygenerowany przez tą aplikację plik JPK za sprzedażą podatnika może być agregowany z plikiem JPK z zakupami, wygenerowanym przez inną aplikację Autora lub przez aplikację innego producenta oprogramowania.


Opis zmian w programie ”Ewidencja magazynowa i fakturowanie sprzedaży” w wersji handlowej na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

W ramach aktualizacji słownika towarów po naciśnięciu kombinacji klawiszy ALT+U można usunąć ze słownika wszystkie pozycje dla których brak jest kart magazynowych. Dotychczas można było usuwać pojedynczą pozycję po naciśnięciu "U".

2024.00/02

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.

2023.00/03

W związku z obowiązkiem elektronicznego przekazywania na żądanie Urzędu Skarbowego dokumentacji księgowej w formie plików JPK Autor aplikacji kontynuował w 2023 roku pracę nad:

  • dostosowaniem do tych żądań struktury i zawartości bazy danych tej aplikacji oraz
  • zaprogramowaniem procedur umożliwiających wygenerowanie na podstawie bazy danych tej aplikacji pliku JPK zgodnego z opublikowaną przez MF strukturą XML pliku JPK o nazwie:
    1. "FAKTURY VAT"; kod systemowy "JPK_FA"; wersja 4
    2. "MAGAZYN"; kod systemowy "JPK_MAG"

Uwagi:

  1. Sorządzany na żądanie Urzędu Skarbowego plik "FAKTURY VAT" (JPK_FA) prawdopodobnie od lipca 2024 roku nie będzie wymagany bowiem jego zawartość będzie identyczna z wymogami struktury Krajowego Systemu e-Faktur.
  2. Plik "MAGAZYN" (JPK_MAG), przekazywany dotychczas do Urzędu Skarbowego na żądanie będzie prawdopodobnie po znowelizowaiu XML-owej struktury elektronicznie przekazywany w sposób cykliczny :

· w trakcie roku do 20 dnia następnego miesiąca dla podatników rozliczających dochód miesięcznie lub do 20 dnia miesiąca kończącego kwartał dla podatników rozliczających dochód kwartalnie

· na koniec roku do upływu terminu dla złożenia zeznania za dany rok podatkowy.

2024.00/04

W związku z planowanym uruchomieniem Krajowego Systemu e-Faktur, autor przygotowywał w 2023 roku zmiany w tej aplikacji, które umożliwią współpracę aplikacji z tym systemem.

Obowiązek przystąpienia podmiotu gospodarczego do Krajowego Systemu e-Faktur, jest przewidywany na dzień 01.07.2024, zarówno po stronie wystawcy jak również po stronie odbiorcy faktury.

W związku z tym autor przewiduje pełne przygotowanie aplikacji do współpracy z KSEF-em dopiero w kwietniu 2024 roku.

Uwaga : w ramach dostosowania aplikacji do Krajowego Systemu e-Faktur konieczne będzie stworzenie procedury generowania na podstawie wystawionych za pomocą tej aplikacji faktur XML-owego pliku o aktualnie obowiązującej strukturze.

2024.00/05

Głównym zadaniem w 2023 roku było zaprogramowanie procedury generowania miesięcznego pliku JPK_VAT zawierającego : część deklaracyjną oraz ewidencyjną ze sprzedażą podatnika.

Plik ten jest od 1 października 2020 roku generowany przez tą aplikację i może być agregowany z plikiem JPK_VAT zawierającym w części ewidencyjnej zakupy podatnika, a wygenerowanym przez inną aplikację Autora do prowadzenia rejestrów zakupu i sprzedaży vat.

Uwaga: wygenerowany przez tą aplikację plik JPK za sprzedażą podatnika może być agregowany z plikiem JPK z zakupami, wygenerowanym przez inną aplikację Autora lub przez aplikację innego producenta oprogramowania.


Opis zmian w programie ”Ewidencja magazynowa i fakturowanie sprzedaży” w wersji produkcyjnej na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

W ramach aktualizacji słownika towarów po naciśnięciu kombinacji klawiszy ALT+U można usunąć ze słownika wszystkie pozycje dla których brak jest kart magazynowych. Dotychczas można było usuwać pojedynczą pozycję po naciśnięciu "U".

2024.00/02

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.

2023.00/03

W związku z obowiązkiem elektronicznego przekazywania na żądanie Urzędu Skarbowego dokumentacji księgowej w formie plików JPK Autor aplikacji kontynuował w 2023 roku pracę nad:

  • dostosowaniem do tych żądań struktury i zawartości bazy danych tej aplikacji oraz
  • zaprogramowaniem procedur umożliwiających wygenerowanie na podstawie bazy danych tej aplikacji pliku JPK zgodnego z opublikowaną przez MF strukturą XML pliku JPK o nazwie:
    1. "FAKTURY VAT"; kod systemowy "JPK_FA"; wersja 4
    2. "MAGAZYN"; kod systemowy "JPK_MAG"

Uwagi:

  1. Sorządzany na żądanie Urzędu Skarbowego plik "FAKTURY VAT" (JPK_FA) prawdopodobnie od lipca 2024 roku nie będzie wymagany bowiem jego zawartość będzie identyczna z wymogami struktury Krajowego Systemu e-Faktur.
  2. Plik "MAGAZYN" (JPK_MAG), przekazywany dotychczas do Urzędu Skarbowego na żądanie będzie prawdopodobnie po znowelizowaiu XML-owej struktury elektronicznie przekazywany w sposób cykliczny :

· w trakcie roku do 20 dnia następnego miesiąca dla podatników rozliczających dochód miesięcznie lub do 20 dnia miesiąca kończącego kwartał dla podatników rozliczających dochód kwartalnie

· na koniec roku do upływu terminu dla złożenia zeznania za dany rok podatkowy.

2024.00/04

W związku z planowanym uruchomieniem Krajowego Systemu e-Faktur, autor przygotowywał w 2023 roku zmiany w tej aplikacji, które umożliwią współpracę aplikacji z tym systemem.

Obowiązek przystąpienia podmiotu gospodarczego do Krajowego Systemu e-Faktur, jest przewidywany na dzień 01.07.2024, zarówno po stronie wystawcy jak również po stronie odbiorcy faktury.

W związku z tym autor przewiduje pełne przygotowanie aplikacji do współpracy z KSEF-em dopiero w kwietniu 2024 roku.

Uwaga : w ramach dostosowania aplikacji do Krajowego Systemu e-Faktur konieczne będzie stworzenie procedury generowania na podstawie wystawionych za pomocą tej aplikacji faktur XML-owego pliku o aktualnie obowiązującej strukturze.

2024.00/05

Głównym zadaniem w 2023 roku było zaprogramowanie procedury generowania miesięcznego pliku JPK_VAT zawierającego : część deklaracyjną oraz ewidencyjną ze sprzedażą podatnika.

Plik ten jest od 1 października 2020 roku generowany przez tą aplikację i może być agregowany z plikiem JPK_VAT zawierającym w części ewidencyjnej zakupy podatnika, a wygenerowanym przez inną aplikację Autora do prowadzenia rejestrów zakupu i sprzedaży vat.

Uwaga: wygenerowany przez tą aplikację plik JPK za sprzedażą podatnika może być agregowany z plikiem JPK z zakupami, wygenerowanym przez inną aplikację Autora lub przez aplikację innego producenta oprogramowania.


Opis zmian w programie ”Rozliczenie transakcji” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora.

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.


Opis zmian w programie ”Rozliczenie produkcji” na rok 2024 :

Jak co roku, autor przygotował nową, zmienioną wersję programu czyli tzw upgrade, dostosowaną do :

  • zmian przepisów prawa,
  • zmian w technologii sprzętu komputerowego,
  • zmian wersji oprogramowania systemowego,
  • potrzeb zgłaszanych przez użytkowników oraz pozbawioną sygnalizowanych przez użytkowników, błędów działania w nietypowych i wyjątkowych sytuacjach.

Program w nowej wersji będzie podczas corocznej wizyty serwisu zainstalowany wyłącznie na komputerze użytkownika. Użytkownik może w każdej chwili ściągnąć ze strony Autora http://www.tomasz-trzcinski.pl samo rozpakowujący się plik z aktualną wersją programu lub skorzystać z zaimplementowanej w programie procedury która pozwala na aktualizację programu w ramach internetowego połączenia programu z serwerem FTP autora

Z opisem zmian w nowej wersji programu można się zapoznać :

· po kliknięciu myszą w link z czerwonym i podkreślonym numerem wersji programu, który pojawia się na ekranie zaraz po uruchomieniu programu,

· po naciśnięciu klawisza F7, alternatywnie po kliknięciu myszą w graficzny przycisk z ikoną „?” w czasie korzystania z programu

Nowa wersja programu na 2024 rok zawiera następujące zmiany szczegółowe :

2024.00/01

Autor zrezygnował z usług serwera FTP "hekko.pl" i w zamian wykupił usługi serwera FTP "jchost.pl" i w związku z tym dokonał odpowiednich zmian w kodzie tego programu.